The Breitling Watch Source Forums

Breitling Watch Information Forums, Navitimer, Chronomat
It is currently Thu Apr 15, 2021 9:30 am

All times are UTC - 8 hours




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Chrono Avenger crown
PostPosted: Thu Oct 29, 2020 2:38 am 
Offline
Breitling Newbie
Breitling Newbie

Joined: Thu Oct 29, 2020 2:26 am
Posts: 2
Likes: 0 post
Liked in: 0 post
Hi, I recently had my Chrono Avenger serviced. It’s now back and I’ve noticed that the crown does not wind in so it is sits flush with the case. Does anybody know if this is a problem and will the watch still be waterproof like this? I will probably send it back to be checked but thought someone here might know if it’s ok to leave it as it is.

Thanks

Andy


Top
 Profile  
Reply with quote  
 Post subject: Re: Chrono Avenger crown
PostPosted: Thu Oct 29, 2020 4:41 am 
Offline
Contributing Moderator
Contributing Moderator
User avatar

Joined: Tue Jul 24, 2007 11:39 am
Posts: 12793
Likes: 141 posts
Liked in: 494 posts
Location: UK
As far as I can recall, the CA doesn't have a separate/removable crown tube as it's an integrated part of the midcase, so unless they replaced the whole midcase for some reason (which is highly unlikely without you knowing), it definitely sounds like an issue with the crown itself. The crown may well have been changed as part of the service (that's not unusual at all), so it sounds like there's an issue with it. I'd recommend sending it back to be checked as obviously the crown is designed to screw-in totally flush and if it's now not doing that I wouldn't fancy the potential risk to its water resistance.

_________________
Driver8

Site Moderator
Image


Top
 Profile  
Reply with quote  
 Post subject: Re: Chrono Avenger crown
PostPosted: Thu Oct 29, 2020 5:01 am 
Offline
Breitling Newbie
Breitling Newbie

Joined: Thu Oct 29, 2020 2:26 am
Posts: 2
Likes: 0 post
Liked in: 0 post
Hi Driver8,

Thanks for the info. The crown wasn’t replaced during the service. They have said that the seals have been replaced and it’s been pressure tested and passed. Doesn’t look right though. I think I’ll send it back and ask them to check it.

Thanks again.


Top
 Profile  
Reply with quote  

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 21 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
 




Powered by phpBB® Forum Software © phpBB Group