The Breitling Watch Source Forums

Breitling Watch Information Forums, Navitimer, Chronomat
 
It is currently Mon Oct 21, 2019 5:41 pm

All times are UTC - 8 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Mon Jun 10, 2019 2:54 pm 
Offline
Breitling Newbie
Breitling Newbie

Joined: Mon Jun 10, 2019 2:44 pm
Posts: 1
Likes: 0 post
Liked in: 0 post
I have a 4 year old Avenger II that has been running well since it was purchased. However, I came across a problem yesterday. When I put the winding stem in the #2 position to advance the date, it would not advance the date. After moving the hands to advance the date, I noticed that the date no longer changed at Midnight but, rather, was changing at 5:30.

I took it over to the AD, who wrote it up and sent it off to Breitling. Question: Does this sound like a serious problem or is it something that can be rather easily addressed when it gets serviced? Thanks in advance for any insight.


Top
 Profile  
Reply with quote  
PostPosted: Thu Aug 01, 2019 12:05 pm 
Offline
Breitling Enthusiast
Breitling Enthusiast

Joined: Sun Aug 24, 2008 9:11 am
Posts: 13
Likes: 0 post
Liked in: 0 post
Received the watch back from Breitling. Everything is working fine. Was charged $675 for full service plus installation of new hands.


Top
 Profile  
Reply with quote  

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: Google [Bot] and 17 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
 


Powered by phpBB® Forum Software © phpBB Group